Back to overview
Resolved

There is a small fire

Jul 24, 2026 at 10:34am UTC
Affected services
Found

Resolved
Jul 24, 2026 at 10:36am UTC

Fire is now out

Updated
Jul 24, 2026 at 10:35am UTC

There fire has grown

Created
Jul 24, 2026 at 10:34am UTC

We're putting it out